PAT(甲級)2019年冬季考試 7-3 Summit (25分)

7-3 Summit (25分)

A summit (峯會) is a meeting of heads of state or government. Arranging the rest areas for the summit is not a simple job. The ideal arrangement of one area is to invite those heads so that everyone is a direct friend of everyone.

Now given a set of tentative arrangements, your job is to tell the organizers whether or not each area is all set.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 200), the number of heads in the summit, and M, the number of friendship relations. Then M lines follow, each gives a pair of indices of the heads who are friends to each other. The heads are indexed from 1 to N.

Then there is another positive integer K (≤ 100), and K lines of tentative arrangement of rest areas follow, each first gives a positive number L (≤ N), then followed by a sequence of L distinct indices of the heads. All the numbers in a line are separated by a space.

Output Specification:

For each of the K areas, print in a line your advice in the following format:

if in this area everyone is a direct friend of everyone, and no friend is missing (that is, no one else is a direct friend of everyone in this area), print Area X is OK…

if in this area everyone is a direct friend of everyone, yet there are some other heads who may also be invited without breaking the ideal arrangement, print Area X may invite more people, such as H. where H is the smallest index of the head who may be invited.

if in this area the arrangement is not an ideal one, then print Area X needs help. so the host can provide some special service to help the heads get to know each other.

Here X is the index of an area, starting from 1 to K.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
2 4 6
3 3 2 1

Sample Output:

Area 1 is OK.
Area 2 is OK.
Area 3 is OK.
Area 4 is OK.
Area 5 may invite more people, such as 3.
Area 6 needs help.

思路:

A1142 Maximal Clique換個背景而已

在這裏插入圖片描述

Code:

#include<iostream> 
#include<vector> 
#include<algorithm>
using namespace std;
const int INF = 0x3fffffff;
const int maxn = 210;
int G[maxn][maxn] = {0};
int main(){
	int n,m,k,l;
	scanf("%d%d",&n,&m);
	for(int i = 0; i < m; i++){
		int c1,c2;
		scanf("%d%d",&c1,&c2);
		G[c1][c2] = G[c2][c1] = 1;
	}
	scanf("%d",&k);
	for(int i = 1; i <= k; i++){
		printf("Area %d ",i);
		bool isOK = true,isMax = true;
		scanf("%d",&l);
		vector<int> h(l);
		for(int j = 0; j < l; j++)
			scanf("%d",&h[j]);
		for(int x = 0; x < l; x++){
			for(int y = x+1; y < l; y++){
				if(G[h[x]][h[y]] == 0){
					isOK = false;
					break;
				}
			}
			if(!isOK) break;
		}
		if(isOK){
			int index = -1;
			for(int x = 1; x <= n; x++){
				for(int y = 0; y < h.size();y ++){
					if(G[x][h[y]] == 0) break;
					if(y == h.size()-1){
						index = x;
						isMax = false;
					}
				}
				if(!isMax) break;
			}
			if(isMax) printf("is OK.\n");
			else printf("may invite more people, such as %d.\n",index);
		}
		else printf("needs help.\n");
	}
		
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章