hdu1350 座標建圖後的最小路徑覆蓋

Taxi Cab Scheme

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1067    Accepted Submission(s): 533


Problem Description
Running a taxi station is not all that simple. Apart from the obvious demand for a centralised coordination of the cabs in order to pick up the customers calling to get a cab as soon as possible, there is also a need to schedule all the taxi rides which have been booked in advance. Given a list of all booked taxi rides for the next day, you want to minimise the number of cabs needed to carry out all of the rides.

For the sake of simplicity, we model a city as a rectangular grid. An address in the city is denoted by two integers: the street and avenue number. The time needed to get from the address a, b to c, d by taxi is |a - c| + |b - d| minutes. A cab may carry out a booked ride if it is its first ride of the day, or if it can get to the source address of the new ride from its latest, at least one minute before the new ride’s scheduled departure. Note that some rides may end after midnight.
 

Input
On the first line of the input is a single positive integer N, telling the number of test scenarios to follow. Each scenario begins with a line containing an integer M, 0 < M < 500, being the number of booked taxi rides. The following M lines contain the rides. Each ride is described by a departure time on the format hh:mm (ranging from 00:00 to 23:59), two integers a b that are the coordinates of the source address and two integers c d that are the coordinates of the destination address. All coordinates are at least 0 and strictly smaller than 200. The booked rides in each scenario are sorted in order of increasing departure time.
 

Output
For each scenario, output one line containing the minimum number of cabs required to carry out all the booked taxi rides.
 

Sample Input
2 2 08:00 10 11 9 16 08:07 9 16 10 11 2 08:00 10 11 9 16 08:06 9 16 10 11
 

Sample Output
1 2

題意:  老司機接客的故事    有很多顧客想要去一些地方   給你起點和終點    問最少需要多少老司機    (起點不計時

主要是座標建圖還是第一次寫到    就寫個題解壓壓驚   其實還是按照題意來就好了     再用數組鏈表實現鄰接表存圖   好像寫煩了  慢了點


#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>

using namespace std;
const int maxn=505;
int n,cnt;
int head[maxn],link[maxn];
bool vis[maxn];
struct point
{
    int x,y;
};
inline int dist(const point& a,const point& b)
{
    return abs(a.x-b.x)+abs(a.y-b.y);
}
struct edge
{
    point st,en;
    int st_time,en_time;
    void cal()
    {
        en_time=st_time+dist(st,en);
    }
} road[maxn];
struct path
{
    int st,en;
    int nxt;
}e[maxn*maxn];

void add(int u,int v)
{
    e[cnt].st=u;
    e[cnt].en=v;
    e[cnt].nxt=head[u];
    head[u]=cnt++;
}

void creat_gragh()
{
    memset(head,-1,sizeof head);
    cnt=0;
    for(int i=1; i<n; i++)
        for(int j=i+1; j<=n; j++)
            if(road[i].en_time+dist(road[i].en,road[j].st)<road[j].st_time) add(i,j);
}

bool dfs(int x)
{
    for(int i=head[x];i!=-1;i=e[i].nxt)
    {
        int t=e[i].en;
        if(!vis[t])
        {
            vis[t]=true;
            if(link[t]==-1||dfs(link[t]))
            {
                link[t]=x;
                return true;
            }
        }
    }
    return false;
}

int hungary()
{
    int num=0;
    memset(link,-1,sizeof link);
    for(int i=1;i<=n;i++)
    {
        memset(vis,false,sizeof vis);
        if(dfs(i)) num++;
    }
    return num;
}

int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    int test,hh,mm;
    scanf("%d",&test);
    while(test--)
    {
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
        {
            scanf("%d:%d %d %d %d %d",&hh,&mm,&road[i].st.x,&road[i].st.y,&road[i].en.x,&road[i].en.y);
            road[i].st_time=hh*60+mm;
            road[i].cal();
        }
        creat_gragh();
        printf("%d\n",n-hungary());
    }
    //fclose(stdin);
    //fclose(stdout);
    return 0;
}





發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章