hdu1002 A + B Problem II

Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2 1 2 112233445566778899 998877665544332211

Sample Output

Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110

AC Code

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <limits.h>
#include <queue>
#define inf 0x3f3f3f3f
#define MAXM 200005
using namespace std;
const double pi=3.141592653589793239,e=2.7182818284590452354;



int main(int argc, char** argv) {
	int n,a[1010],b[1010],k=0;
	char c[1010],d[1010];
	cin>>n;
	while(++k<=n)
	{
		int i,j,m,ch=0;
		
		
		
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		cin>>c>>d;
		cout<<"Case "<<k<<":"<<endl;
		cout<<c<<" + "<<d<<" = ";
		m=strlen(c);
		for(i=0;i<m;i++)
		{
			a[m-i-1]=c[i]-'0';
		}
		m=strlen(d);
		for(i=0;i<m;i++)
		{
			b[m-i-1]=d[i]-'0';
		}
		for(i=0;i<1010;i++)
		{
			int tmp;
			tmp=a[i]+b[i]+ch;
			a[i]=tmp%10;
			ch=tmp/10;
		}
		for(i=1009;i>=0;i--)
			if(a[i]!=0) break;
		for(j=i;j>=0;j--)
			cout<<a[j];
		if(k!=n) cout<<endl<<endl;
		else cout<<endl;
	}
	return 0;
}





發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章