PAT 1086. Tree Traversals Again (25)

1086. Tree Traversals Again (25)

時間限制
200 ms
內存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1

這道題首先根據輸入建立一個二叉樹,然後後序遍歷這個二叉樹即可。代碼如下: 

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <cstring>
using namespace std;
typedef struct node{
	int element;
	node* left;
	node* right;
	bool popped;
	node(){
		left=NULL;
		right=NULL;
		popped=false;
	}
}node;
node* root;
node* push(node* x,int element)
{
	if(x==NULL)
	{
		x=new node;
		x->element=element;
	}
	else if(x->popped)
		x->right=push(x->right,element);
	else
		x->left=push(x->left,element);
	return x;
}
bool pop(node* x)
{
	if(x==NULL)
		return false;
	if(x->popped)
	{
		if(!pop(x->right))
			return false;
	}
	else if(!pop(x->left))
		x->popped=true;
	return true;
}
void postorder(node* x)
{
	if(x==NULL)
		return;
	postorder(x->left);
	postorder(x->right);
	if(x!=root)
		cout<<x->element<<" ";
	else
		cout<<x->element;
	return;
}
int main(void)
{
	int N,ele;
	cin>>N;
	int step=2*N;
	string raw;
	cin>>raw>>ele;
	getchar();
	root=new node;
	root->element=ele;
	for(int i=1;i<step;i++)
	{
		cin>>raw;
		if(raw[1]=='u')
		{
			cin>>ele;
			root=push(root,ele);
		}
		else
			pop(root);
	}
	postorder(root);
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章