PAT 1097. Deduplication on a Linked List (25)

1097. Deduplication on a Linked List (25)

時間限制
300 ms
內存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue

Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (<= 105) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the position of the node, Key is an integer of which absolute value is no more than 104, and Next is the position of the next node.

Output Specification:

For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854
Sample Output:
00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1

同樣是一道鏈表處理問題,和之前的鏈表題目一個風格,注意點也差不多。代碼如下:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <map>
#include <vector>
using namespace std;
typedef struct node{
	int addr;
	int element;
	int next;
}node;
int main(void)
{
	int head,N,i;
	cin>>head>>N;
	map<int,node> raw;
	for(i=0;i<N;i++)
	{
		node temp;
		cin>>temp.addr>>temp.element>>temp.next;
		raw[temp.addr]=temp;
	}
	node end;
	end.addr=-1;
	raw[-1]=end;
	map<int,int> count;
	vector<node> rem;
	vector<node> dup;
	while(raw[head].addr!=-1)
	{
		int x=abs(raw[head].element);
		if(count.count(x)<=0)
		{
			count[x]=1;
			rem.push_back(raw[head]);
		}
		else
			dup.push_back(raw[head]);
		head=raw[head].next;
	}
	if(rem.size()>1)
		for(i=0;i<rem.size()-1;i++)
			printf("%05d %d %05d\n",rem[i].addr,rem[i].element,rem[i+1].addr);
	if(rem.size())
		printf("%05d %d -1\n",rem[rem.size()-1].addr,rem[rem.size()-1].element);
	if(dup.size()>1)	
		for(i=0;i<dup.size()-1;i++)
			printf("%05d %d %05d\n",dup[i].addr,dup[i].element,dup[i+1].addr);
	if(dup.size())
		printf("%05d %d -1",dup[dup.size()-1].addr,dup[dup.size()-1].element);
}

 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章