【PAT】A1129 Recommendation System (25point(s))


Author: CHEN, Yue
Organization: 浙江大學
Time Limit: 400 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB

A1129 Recommendation System (25point(s))

Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user’s preference by the number of times that an item has been accessed by this user.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers: N (≤ 50,000), the total number of queries, and K (≤ 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing – for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.

Output Specification:

For each case, process the queries one by one. Output the recommendations for each query in a line in the format:

query: rec[1] rec[2] … rec[K]

where query is the item that the user is accessing, and rec[i] (i=1, … K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

Sample Input:

12 3
3 5 7 5 5 3 2 1 8 3 8 12

Sample Output:

5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8

Code

#include <stdio.h>
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
vector<int> res;
int cntNum[50100],invec[50100];
bool cmp(int a,int b){
    if(cntNum[a]==cntNum[b])    return a<b;
    else    return cntNum[a]>cntNum[b];
}
int main(){
    int n,k,q;
    scanf("%d %d",&n,&k);
    for(int i=0;i<n;i++){
        scanf("%d",&q);
        if(i!=0){
            printf("%d:",q);
            for(int j=0;j<k&&j<res.size();j++)
                printf(" %d",res[j]);
            printf("\n");
        }
        cntNum[q]++;
        if(invec[q]==0){
            res.push_back(q);
            invec[q]=1;
        }
        sort(res.begin(),res.end(),cmp);
        if(res.size()>k){
            invec[res[res.size()-1]]=0;
            res.pop_back();
        }
    }
    return 0;
}

Analysis

-按照輸入數據出現的頻率有k個推薦位。

-注意,爲了不超時,res vector中,只需要保存k個數字,否則一直排序會超時。

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章