PAT 1098. Insertion or Heap Sort (25)

1098. Insertion or Heap Sort (25)

時間限制
100 ms
內存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0
Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0
Sample Input 2:
10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9
Sample Output 2:
Heap Sort
5 4 3 1 0 2 6 7 8 9

這道題和之前那道“ insertion or merge sort" 幾乎一樣,還是通過Insertion入手,判斷出是不是Insertion Sort。然後根據判斷結果用不同的sort方法再迭代排序一次即可。 代碼如下:

 

#include <iostream>
#include <algorithm>
#include <cmath>
#include <map>
#include <vector>
using namespace std;
int N;
vector<int> raw;
vector<int> sorted;
void heapsort()
{
	int i,temp,child,pos;
	for(i=N-1;i>0;i--)
		if(sorted[i]<sorted[0])
			break;
	temp=sorted[i];
	sorted[i--]=sorted[0];
	for(pos=0;pos*2<i;pos=child)
	{
		child=pos*2+1;
		if(child<i&&sorted[child+1]>sorted[child])
			child++;
		if(temp>sorted[child])
			break;
		else
			sorted[pos]=sorted[child];
	}
	sorted[pos]=temp;
}
int main(void)
{
	int i,j;
	cin>>N;
	raw.resize(N);
	sorted.resize(N);
	bool IorH=true; // IorH is ture if it's insertion sort, otherwise false
	for(i=0;i<N;i++)
		cin>>raw[i];
	for(i=0;i<N;i++)
		cin>>sorted[i];
	for(i=0;i<N-1;i++)
		if(sorted[i]>sorted[i+1])
			break;
	i++;
	for(j=i;j<N;j++)
		if(raw[j]!=sorted[j])
			break;
	if(j<N)
		IorH=false;		
	if(IorH)
	{
		cout<<"Insertion Sort"<<endl;
		sort(sorted.begin(),sorted.begin()+i+1);
	}
	else
	{
		cout<<"Heap Sort"<<endl;
		heapsort();
	}
	for(j=0;j<N-1;j++)
		cout<<sorted[j]<<" ";
	cout<<sorted[N-1];		
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章