【PAT】A1095 Cars on Campus (30point(s))


Author: CHEN, Yue
Organization: 浙江大學
Time Limit: 300 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB

A1095 Cars on Campus (30point(s))

Zhejiang University has 8 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (≤10^​4​​ ), the number of records, and K (≤8×10^​4​​ ) the number of queries. Then N lines follow, each gives a record in the format:

plate_number hh:mm:ss status

where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each in record is paired with the chronologically next record for the same car provided it is an out record. Any in records that are not paired with an out record are ignored, as are out records not paired with an in record. It is guaranteed that at least one car is well paired in the input, and no car is both in and out at the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in ascending order of the times.

Output Specification:

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:

16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00

Sample Output:

1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09

Code

#include <bits/stdc++.h>
using namespace std;
typedef struct car{
	char id[10];
	int time,flag=0;
}car;
vector<string> result;
unordered_map<string, int> parktime;
int tos(int h, int m, int s){return h * 3600 + m * 60 + s;}
bool cmp(car a, car b){
	if (strcmp(a.id, b.id)) // 如果不相等
        return strcmp(a.id, b.id) < 0;
	else
        return a.time < b.time;
}
bool cmp1(car a, car b){
    return a.time < b.time;
}
int main(){
	int n, k, num = 0, maxtime = -1;
	int h, m, s;
	scanf("%d %d", &n, &k);
	vector<car> cars(n),vtemp;
	for (int i = 0; i < n; i++){
        char status[5];
		scanf("%s %d:%d:%d %s", cars[i].id, &h, &m, &s, status);
		if(!strcmp(status,"in")) cars[i].flag=1;
        else    cars[i].flag=-1;
		cars[i].time = tos(h, m, s);
	}
	sort(cars.begin(), cars.end(), cmp);
	int nowtime = 0, index = 0;
	for (int i = 0; i < cars.size()-1; i++){
        if(!strcmp(cars[i].id,cars[i+1].id) && cars[i].flag==1&&cars[i+1].flag==-1){
            parktime[cars[i].id] += cars[i+1].time-cars[i].time;
            vtemp.push_back(cars[i]);
            vtemp.push_back(cars[i+1]);
        }
	}
    sort(vtemp.begin(), vtemp.end(), cmp1);
    vector<int> carnow(n);
    for(int i = 0; i < vtemp.size(); i++) {
        if(i == 0)  carnow[i] += vtemp[i].flag;
        else    carnow[i] = carnow[i-1] + vtemp[i].flag;
    }
	for (int i = 0; i < k; i++){
		scanf("%d:%d:%d", &h, &m, &s);
		nowtime = tos(h, m, s);
		int j;
		for(j=index;j<vtemp.size();j++){
            if(vtemp[j].time>nowtime){
                printf("%d\n",carnow[j-1]);
                break;
            }
            else if(j==vtemp.size()-1){
                printf("%d\n",carnow[j]);
            }
		}
		index=j;
	}
	for (unordered_map<string, int>::iterator it = parktime.begin(); it != parktime.end(); it++){
		if(it->second>maxtime){
            maxtime=it->second;
            result.clear();
            result.push_back(it->first);
		}
		else if(it->second == maxtime)   result.push_back(it->first);
	}
	sort(result.begin(),result.end());
	for(int i=0;i<result.size();i++)    printf("%s ", result[i].c_str());
	printf("%02d:%02d:%02d", maxtime / 3600, maxtime % 3600 / 60, maxtime % 60);
	return 0;
}

Analysis

-對於此類題,最好將時間全部轉化爲秒(統一單位)。

-給出n輛車的車牌號,時間,狀態(出/入)。再給出k個時間點,要求每個時間點校園內有幾輛車。最後輸出本日在校園內停車時間最長的車的車牌號,多輛車按車牌字母順序排列,以及停車時長。

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章