PAT 1096. Consecutive Factors (20)

1096. Consecutive Factors (20)

時間限制
400 ms
內存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3*5*6*7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<231).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format "factor[1]*factor[2]*...*factor[k]", where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:
630
Sample Output:
3
5*6*7

一開始想了半天,越想越複雜,後來瞄了一眼這道題的分數。。嗯。。既然只值20分,那就試試暴力破解吧!於是就用最簡單的方法,從2開始連乘,一個個試過去,找到最長的。結果這樣的代碼就AC了。。。。代碼如下:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
using namespace std;

int main(void)
{
	int N,max=0,temp,count;
	cin>>N;
	vector<int> result;
	vector<int> t;
	for(int i=2;i<=sqrt(N);i++)
	{
		if(N%i!=0)
			continue;
		temp=N/i;
		count=1;
		t.clear();
		t.push_back(i);
		for(int j=i+1;j<=sqrt(N);j++)
		{
			if(temp%j!=0)
				break;
			else
			{
				t.push_back(j);
				temp/=j;
				count++;
			}
		}
		if(count>max)
		{
			max=count;
			result=t;
		}
	}
	if(result.size()==0)
	{
		cout<<1<<endl<<N;
		return 0;
	}
	cout<<max<<endl;
	for(int i=0;i<result.size()-1;i++)
		cout<<result[i]<<"*";
	cout<<result[result.size()-1];
}

 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章