【PAT】A1117 Eddington Number (25point(s))


Author: CHEN, Yue
Organization: 浙江大學
Time Limit: 250 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB

A1117 Eddington Number (25point(s))

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an “Eddington number”, E – that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington’s own E was 87.
Now given everyday’s distances that one rides for N days, you are supposed to find the corresponding E (≤N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10^​5​​ ), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N days.

Sample Input:

10
6 7 6 9 3 10 8 2 7 8

Sample Output:

6

Code

#include <stdio.h>
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
vector<int> dis;
bool cmp(int a,int b){return a>b;}
int main(){
    int n,maxe=0;
    scanf("%d",&n);
    dis.resize(n);
    for(int i=0;i<n;i++)    scanf("%d",&dis[i]);
    sort(dis.begin(),dis.end(),cmp);
    while(maxe<n&&dis[maxe]>maxe+1) maxe++;
    printf("%d",maxe);
    return 0;
}

Analysis

-假設騎車E天,則這E天內每天所騎行距離必須大於E。

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章