【PAT】A1076 Forwards on Weibo (30point(s))


Author: CHEN, Yue
Organization: 浙江大學
Time Limit: 3000 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB

A1076 Forwards on Weibo (30point(s))

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID’s for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

Code

#include <bits/stdc++.h>
using namespace std;
vector<int> followed[1010];
int visit[1010];
struct node{
    int id,layer;
};
int BFS(node root,int l){
    memset(visit,0,sizeof(visit));
    visit[root.id]=1;
    queue<node> q;
    q.push(root);
    int cnt=0;
    while(!q.empty()){
        node temp=q.front();
        q.pop();
        for(int i=0;i<followed[temp.id].size();i++){
            if(visit[followed[temp.id][i]]==0 && temp.layer<l){
                q.push({followed[temp.id][i],temp.layer+1});
                visit[followed[temp.id][i]]=1;
                cnt++;
            }
        }
    }
    return cnt;
}
int main(){
    int n,l,m,k,temp;
    cin>>n>>l;
    for(int i=1;i<=n;i++){
        cin>>m;
        for(int j=0;j<m;j++){
            cin>>temp;
            followed[temp].push_back(i);
        }
    }
    cin>>k;
    while(k--){
        cin>>temp;
        printf("%d\n",BFS({temp,0},l));
    }
    return 0;
}

Analysis

-已知一些關注關係

-給出一個人,求其三級關注中的總人數。其實就是求有向圖中,從一點出發,向外擴3層所新加入的結點數。

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章