【PAT】A1080 Graduate Admission (30point(s))


Author: CHEN, Yue
Organization: 浙江大學
Time Limit: 250 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB

A1080 Graduate Admission (30point(s))

It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.

Each applicant will have to provide two grades: the national entrance exam grade G​E​​ , and the interview grade G​I​​ . The final grade of an applicant is (G​E​​ +G​I​​ )/2. The admission rules are:

The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.

If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade G​E​​ . If still tied, their ranks must be the same.

Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one’s turn to be admitted; and if the quota of one’s most preferred shcool is not exceeded, then one will be admitted to this school, or one’s other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.

If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

Input Specification:

Each input file contains one test case.

Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.

In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.

Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant’s G​E​​ and G​I​​ , respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M−1, and the applicants are numbered from 0 to N−1.

Output Specification:

For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants’ numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

Sample Input:

11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4

Sample Output:

0 10
3
5 6 7
2 8

1 4

Code

#include <bits/stdc++.h>
using namespace std;
struct stu{
    int Ge,Gi,num;
    double fin;			// 總分需要除二,使用double型更好
    vector<int> q;
};
bool cmp1(stu &a, stu &b){	// 使用引用傳參可以節約時間
    if(a.fin!=b.fin)    return a.fin>b.fin;
    else    return a.Ge>b.Ge;
}
int main(){
    int n,m,k;
    cin>>n>>m>>k;
    vector<int> sch_quota(m),sch_app[n];
    vector<stu> stus(n);
    for(int i=0;i<m;i++)    cin>>sch_quota[i];
    for(int i=0;i<n;i++){
        cin>>stus[i].Ge>>stus[i].Gi;
        stus[i].q.resize(k);
        for(int j=0;j<k;j++)    cin>>stus[i].q[j];
        stus[i].fin=stus[i].Ge/2 + stus[i].Gi/2;		// 這樣寫防止溢出
        stus[i].num=i;
    }
    sort(stus.begin(),stus.end(),cmp1);
    for(int i=0;i<n;i++){
        for(int j=0;j<k;j++){
            int nowsch=stus[i].q[j], nownum=stus[i].num;
            if(sch_quota[nowsch] > 0){	// 若志願學校還缺人
                sch_quota[nowsch]--;
                sch_app[nowsch].push_back(nownum);
                break;
            }
            else if(sch_quota[nowsch]==0
                && sch_app[nowsch].size()>0
                && stus[sch_app[nowsch].back()].fin==stus[nownum].fin
                && stus[sch_app[nowsch].back()].Ge==stus[nownum].Ge){	// 若某學生與其志願學校招收的最後一名排名相同(本題使用總成績和Ge成績作爲排名的標準)
                sch_app[nowsch].push_back(nownum);
                break;
            }
        }
    }
    for(int i=0;i<m;i++){
        sort(sch_app[i].begin(),sch_app[i].end());
        for(int j=0;j<sch_app[i].size();j++){
            if(j==0)    printf("%d",sch_app[i][j]);
            else    printf(" %d",sch_app[i][j]);
        }
        printf("\n");
    }
	return 0;
}

Analysis

-已知一些學生的成績和他們的志願,一些學校的招收名額。

-求這些學校分別可以招收到哪些學生。

-解題時先將學生按照總成績和Ge成績進行排序。然後按照順序選擇學校。

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章