hdu1709 The Balance (放入+取出 01揹包)

The Balance

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6973    Accepted Submission(s): 2874


Problem Description
Now you are asked to measure a dose of medicine with a balance and a number of weights. Certainly it is not always achievable. So you should find out the qualities which cannot be measured from the range [1,S]. S is the total quality of all the weights.
 

Input
The input consists of multiple test cases, and each case begins with a single positive integer N (1<=N<=100) on a line by itself indicating the number of weights you have. Followed by N integers Ai (1<=i<=N), indicating the quality of each weight where 1<=Ai<=100.
 

Output
For each input set, you should first print a line specifying the number of qualities which cannot be measured. Then print another line which consists all the irrealizable qualities if the number is not zero.
 

Sample Input
3 1 2 4 3 9 2 1
 

Sample Output
0 2 4 5
 

Source



解析:1.正向:往揹包裏面放東西,求出那些經過相加之後能得到的體積。

           2.逆向:從揹包裏面拿出東西,求出哪些組合相減之後能得到的體積。

代碼:

#include<cstdio>
#include<queue>
#include<cstring>
#define ms(a) memset(a,0,sizeof(a))
using namespace std;

const int maxn=1e2;
const int maxsum=1e4;
int a[maxn+10];
bool f[maxsum+10];
queue<int> q;

int main()
{
  freopen("1.in","r",stdin);
  int n,i,j,sum;
  while(scanf("%d",&n)==1)
    {
      for(sum=0,i=1;i<=n;i++)
	    scanf("%d",&a[i]),sum+=a[i];
	  ms(f),f[0]=1;
      for(i=1;i<=n;i++)
        for(j=sum;j>=a[i];j--)f[j]|=f[j-a[i]];
      for(i=1;i<=n;i++)
        for(j=1;j+a[i]<=sum;j++)f[j]|=f[j+a[i]];
        
      for(j=0,i=1;i<=sum;i++)if(!f[i])q.push(i),j++;
      printf("%d\n",j);
      if(j==0)continue;
      printf("%d",q.front()),q.pop();
      while(!q.empty())printf(" %d",q.front()),q.pop();
      printf("\n");
	}
  return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章