poj2386 Lake Counting (深搜)

Lake Counting
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 25416   Accepted: 12803

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

Source



解析:直接看代碼吧。

代碼:

#include<cstdio>
using namespace std;

const int maxn=1e2;
int n,m;
char s[maxn+10][maxn+10];

void dye(int x,int y)
{
  int i,j;
  s[x][y]='.';
  for(i=-1;i<=1;i++)
    for(j=-1;j<=1;j++)
      if(1<=x+i && x+i<=n && 
	     1<=y+j && y+j<=m &&
		 s[x+i][y+j]=='W')dye(x+i,y+j);
}

int main()
{
  freopen("1.in","r",stdin);
  int i,j,ans;
  while(scanf("%d%d\n",&n,&m)==2)
    {
      for(i=1;i<=n;i++)
        for(j=1;j<=m;j++)
          scanf("%c\n",&s[i][j]);
      for(ans=0,i=1;i<=n;i++)
        for(j=1;j<=m;j++)
          if(s[i][j]=='W')dye(i,j),ans++;
      printf("%d\n",ans);
	} 
  return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章