poj3617 Best Cow Line (貪心)

Best Cow Line
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14855   Accepted: 4221

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

Source

[Submit]   [Go Back]   [Status]   [Discuss]



解析:從首尾兩個字符當中取字典序最小的一個輸出,若兩個字母相同,則比較下一個字母的大小,以此決定輸出首字母還是尾字母。

代碼:

#include<cstdio>
#include<algorithm>
using namespace std;

const int maxn=2e3;
char s[maxn+10];

bool left(int l,int r)
{
  while(l<r)
    {
      if(s[l]<s[r])return 1;
      if(s[l]>s[r])return 0;
      l++,r--;
	}
  return 1;
}

int main()
{
  freopen("1.in","r",stdin);
  
  int n,i,l,r;
  while(scanf("%d\n",&n)==1)
    {
      for(i=1;i<=n;i++)scanf("%c\n",&s[i]);
      l=1,r=n;
	  for(i=1;i<=n;i++)
	    {
          if(left(l,r))printf("%c",s[l]),l++;
          else printf("%c",s[r]),r--;
          if(i%80==0 || i==n)printf("\n");
		} 
	}
  return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章