POJ 3641 Pseudoprime numbers(快速冪,素數)

Pseudoprime numbers
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8886   Accepted: 3746

Description

Fermat's theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

Sample Input

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

Sample Output

no
no
yes
no
yes
yes

基於費馬小定理出的題。關於P是不是素數,讀了很久很久。這段英文對我來說跟斯瓦西里語一樣(微笑臉)
總之有兩個要求,1,p不是素數,2,a的p次方對p取餘等於a對p取餘。
由於數比較大要用快速冪和long long
最最關鍵的一點,p的輸入在前,a的輸入在後。因爲輸入反了,WA到懷疑人生(大大的微笑臉)
#include<cstdio>
long long check(long long x)
{
	long long i;
	for(i=2;i*i<=x;i++)
	{
		if(x%i==0)
		return 0;
	}
	return 1;
}
long long fff(long long x,long long y,long long z)
{
	long long ans=1;
	while(y>0)
	{
		if(y%2==1)
		ans=(ans*x)%z;
		x=(x*x)%z;
		y=y/2;
	}
	return ans;
}
int main()
{
	long long a,p;
	while(~scanf("%lld%lld",&p,&a))
	{
		if(a==0&&p==0)
		break;
		if(check(p))
		printf("no\n");
		else
		{
			if(fff(a,p,p)==a%p)
			printf("yes\n");
			else
			printf("no\n");
		}
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章