HDOJ 5363 Key Set

Key Set

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1870    Accepted Submission(s): 983


Problem Description
soda has a set S with n integers {1,2,,n}. A set is called key set if the sum of integers in the set is an even number. He wants to know how many nonempty subsets of Sare key set.
 

Input
There are multiple test cases. The first line of input contains an integer T (1T105), indicating the number of test cases. For each test case:

The first line contains an integer n (1n109), the number of integers in the set.
 

Output
For each test case, output the number of key sets modulo 1000000007.
 

Sample Input
4 1 2 3 4
 

Sample Output
0 1 3 7
快速冪和排列組合結合的題,題解有空補上(其實是自己還不清楚)
#include<stdio.h>
#include<string.h>
long long MI(long long a,long long b)
{
	long long ans=1;
	while(b>0)
	{
		if(b%2==1)
		ans=(ans*a)%1000000007;
		b=b/2;
		a=(a*a)%1000000007;
	}
	return ans;
}
int main()
{
	int t;
	long long n;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lld",&n);
		printf("%lld\n",MI(2,n-1)-1);
	}
}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章