Number Sequence

Number Sequence

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 45   Accepted Submission(s) : 14

Font: Times New Roman | Verdana | Georgia

Font Size:

Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5

Author

CHEN, Shunbao

Source

ZJCPC2004
#include<stdio.h>
int main()
{
    int a,b,n,i,t[1000],flag,m,num;
    while(scanf("%d%d%d",&a,&b,&n))
    {
        if(a==0&&b==0&&n==0) break;
       t[1]=1;t[2]=1;
       for(i=3;i<=200;i++)
       {
            t[i]=(a*t[i-1]+b*t[i-2])%7;
       }
       flag=1;
       for(i=3;i<=200&&flag==1;i++)
       {
           if(t[i]==1&&t[i+1]==1) flag=0;
           
       }
    
      
       m=i-2;
       num=n%m;
       if(num==0) printf("%d\n",t[m]);
       else
       printf("%d\n",t[num]);
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章