HDU-Add More Zero

Add More Zero

    Time Limit: 2000/1000 MS (Java/Others)                                  Memory Limit:  131072/131072 K (Java/Others)
   Total Submission(s): 2245    Accepted Submission(s): 1053

Problem Description
There is a youngster known for amateur propositions concerning several mathematical hard problems.
Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between 0 and (2m−1) (inclusive).
As a young man born with ten fingers, he loves the powers of 10 so much, which results in his eccentricity that he always ranges integers he would like to use from 1 to 10k (inclusive).
For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could.
Given the positive integer m, your task is to determine maximum possible integer k that is suitable for the specific supercomputer.

Input

The input contains multiple test cases. Each test case in one line contains only one positive integer m, satisfying 1≤m≤105.

Output

For each test case, output “Case #x: y” in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.

Sample Input

1
64

Sample Output

Case #1: 0
Case #2: 19

代碼:

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;

int main()
{
    int n,l=1,m;
    while(~scanf("%d",&n))
    {
        m=n*(log10(2));
        printf("Case #%d: %d\n",l,m);
        l++;
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章