(最短路-floyd+鄰接矩陣)PKU-1125 Stockbroker Grapevine

原題鏈接  http://poj.org/problem?id=1125 

Stockbroker Grapevine

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

 

問題:爲達到某些目的,商家會散佈一些假信息。但是每個人只相信他們認爲可靠的人那裏獲取信息。一個消息從消息源轉到下面有一定的時間。一個消息的持續時間就是它從開始傳播到無法傳播爲止的最長時間。現給出一個消息網絡以及每條渠道所用時間,在網絡中選擇一個人作爲消息源,使得消息的持續時間最短。

思路:用Floyd算法求每點之間的最短距離,一個點到其他點的最大距離就是該點的傳播時間。找出最小即可。

Source Code

/*
最短路徑算法:floyd_warshall
*/
#include <iostream>
using namespace std;

#define Max 105
#define INF 10000000

int map[Max][Max];
int result[Max][Max];
int pre[Max][Max];

//多源最短路徑,floyd_warshall算法,複雜度O(n^3)
//求出所有點對之間的最短路經,傳入圖的大小points 和鄰接陣map[][]
//返回各點間最短距離result[]和路徑pre[],pre[i][j]記錄i到j最短路徑上j的父結點
//可更改路權類型,路權必須非負!
void floyd_warshall(int points){
	int i,j,k;
	for (i = 0; i < points; i++) {
		for (j = 0; j < points; j++) {
			result[i][j] = map[i][j];
			pre[i][j] = (i == j) ? -1 : i;
		}
	}

	//探測點一定要放在最前面(WA多次)
	for (k = 0; k < points; k++) {
		for (i = 0; i < points; i++) {
			for (j = 0; j < points; j++) {
				if (i != j && (result[i][k] + result[k][j] < result[i][j])) {
					result[i][j] = result[i][k] + result[k][j];
					pre[i][j]=pre[k][j];
				}
			}
		}
	}
 }

int main() {
	int points, lines, end, len;
	int i, j;
	while (scanf("%d", &points) !=EOF) {

		if (points == 0){
			break;
		}

		for (i = 0; i <= points; i++) {
			for (j = 0; j <= points; j++) {
				map[i][j] = INF;
			}
		}

		for (i = 1; i <= points; i++) {
			scanf("%d", &lines);
			for (j = 0; j < lines; j++) {
				scanf("%d %d", &end, &len);
				map[i - 1][end - 1] = len;
			}
		}

		floyd_warshall(points);

		int index = -1;
		int MaxTime, MinTime;
		MinTime = INF;
		for (i = 0; i < points; i++) {
			MaxTime = -1;
			for (j = 0; j < points; j++) {
				if (i == j) {
					continue;
				}
				if (result[i][j] > MaxTime) {
					MaxTime = result[i][j];
				}
			}
			if (MinTime > MaxTime) {
				MinTime = MaxTime;
				index = i;
			}
		}

		if (MinTime == INF) {
			printf("disjoint\n");
		} else {
			printf("%d %d\n", index + 1, MinTime);
		}		
	}

}


 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章