(最小生成樹-Prim)PKU-1258 Agri-Net

原題鏈接 http://poj.org/problem?id=1258

Agri-Net

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28
 
<span style="font-size:24px;color:#333399;">Source Code</span>
/*
最小生成樹 Prim
*/

#include <iostream>
using namespace std;

#define Max 102
#define INF 1000000;
int map[Max][Max];

int prim(int points) {

	int i, j, k, MaxDis, result;
	bool searched[Max];
	int dis[Max];

	//初始化,以0爲起點
	result = 0;
	memset(searched, 0, sizeof(searched));
	for (i = 1; i < points; i++) {
		dis[i] = map[0][i];
	}
	
	searched[0] = 1;
	k = 0;
	for (i = 1; i < points; i++) {
		MaxDis = INF;
		//每次找出最近的點
		for (j = 0; j < points; j++) {
			if (!searched[j] && MaxDis > dis[j]) {
				MaxDis = dis[j];
				k = j;
			} 
		}

		//更新當前點集到其餘未加入的點的最短距離
	    searched[k] = 1;
		result += MaxDis;
		for (j = 0; j < points; j++) {
			if (!searched[j] && map[k][j] < dis[j]) {
				dis[j] = map[k][j];
			}
		}
	}

	return result;
}

int main() {
	int i, j, farms;
	while (scanf("%d", &farms) != EOF) {
		for (i = 0; i < farms; i++) {
			for (j = 0; j < farms; j++) {
				scanf("%d", &map[i][j]);
			}
		}
		printf("%d\n", prim(farms));
	}

}


 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章