POJ 3041


Asteroids
Time Limit: 1000MS   Memory Limit: 65536KB   64bit IO Format: %I64d & %I64u

            

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space.
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS:
The following diagram represents the data, where "X" is an asteroid and "." is empty space:
X.X
.X.
.X.


OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source



題意: 在一張地圖上,有一些小行星,你有一個武器,每使用一次就能摧毀一行或一列的行星,求摧毀所有行星需要使用的次數~ ~
思路: 想不到是二分圖匹配啊 = = 所有的x作爲一個集合,所有的y作爲一個集合,x和y之間連邊。轉化爲最小點覆蓋問題, 最少覆蓋的點數 = 最大匹配數,orz。

AC代碼:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int n, k;
int g[505][505], linker[505], vis[505];
int Find(int x)
{
  for(int i = 1;i <= n;i ++)
  {
    if(!vis[i] && g[x][i])
	{
	  vis[i] = 1;
	  if(linker[i] == 0 || Find(linker[i]))
	  {
	    linker[i] = x;
	    return 1;
	  }
	}
  }
  return 0;
}
int main()
{
	int a, b, ans;
	while(scanf("%d%d", &n, &k) != EOF)
	{
	  ans = 0;
	  memset(g, 0, sizeof(g));
	  memset(linker, 0, sizeof(linker));
	  while(k --)
	  {
	   scanf("%d%d",&a, &b);
	   g[a][b] = 1;
	  }
	  for(int i = 1;i <= n;i ++)
	  {
	   memset(vis, 0, sizeof(vis));
	   if(Find(i)) ans ++;
	  }
	  printf("%d\n",ans);
    }
	return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章