【杭電】[2196]Computer

Computer

Time Limit: 1000/1000 MS (Java/Others)

Memory Limit: 32768/32768 K (Java/Others)

Problem Description
A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information. 

Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4. 
Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
 
Sample Input
5 1 1 2 1 3 1 1 1 

Sample Output
3 2 3 4 4
求樹中所有點的最遠距離
先找任意點的最遠點u,在找u的最遠點v,在這個過程中記錄u到每個點的距離dis[0][i],再以v爲起點尋找最遠點,記錄v到每個點的距離dis[1][i],則各個點的最遠距離爲max(dis[0][i],dis[1][i])
#include<stdio.h>
#include<string.h>
int n,m;
int t,max;
int dis[2][10200];
int head[10200];
int headcnt;
struct List {
	int u,v,w;
	int next;
} edge[20200];
int f(int a,int b) {
	return a>b?a:b;
}
void dfs(int u,int v,int w,int flag) {
	if(max<w)
		max=w,t=u;
	dis[flag][u]=w;
	for(int i=head[u]; i!=-1; i=edge[i].next) {
		if(edge[i].v!=v) {
			dfs(edge[i].v,u,w+edge[i].w,flag);
		}
	}
}
void add(int u,int v,int w) {
	edge[headcnt].u=u;
	edge[headcnt].v=v;
	edge[headcnt].w=w;
	edge[headcnt].next=head[u];
	head[u]=headcnt++;
}
int main() {
	while(scanf("%d",&n)!=EOF) {
		headcnt=0;
		memset(head,-1,sizeof(head));
		for(int i=2; i<=n; i++) {
			int v,w;
			scanf("%d %d",&v,&w);
			add(i,v,w);
			add(v,i,w);
		}
		max=0;
		dfs(1,0,0,0);
		max=0;
		dfs(t,0,0,0);
		dfs(t,0,0,1);
		for(int i=1; i<=n; i++) {
			printf("%d\n",f(dis[0][i],dis[1][i]));
		}
	}
	return 0;
}

題目地址:【杭電】[2196]Computer
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章