Jump and Jump... HDU 5162



Jump and Jump...

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 664    Accepted Submission(s): 370


Problem Description
There are n kids and they want to know who can jump the farthest. For each kid, he can jump three times and the distance he jumps is maximum distance amount all the three jump. For example, if the distance of each jump is (10, 30, 20), then the farthest distance he can jump is 30. Given the distance for each jump of the kids, you should find the rank of each kid.
 

Input
There are multiple test cases. The first line of input contains an integer T (1T100), indicating the number of test cases. For each test case: The first line contains an integer n (2n3), indicating the number of kids. For the next n lines, each line contains three integers ai,bi and ci (1ai,bi,ci,300), indicating the distance for each jump of the i-th kid. It's guaranteed that the final rank of each kid won't be the same (ie. the farthest distance each kid can jump won't be the same).
 

Output
For each test case, you should output a single line contain n integers, separated by one space. The i-th integer indicating the rank of i-th kid.
 

Sample Input
2 3 10 10 10 10 20 30 10 10 20 2 3 4 1 1 2 1
 

Sample Output
3 1 2 1 2
Hint
For the first case, the farthest distance each kid can jump is 10, 30 and 20. So the rank is 3, 1, 2.
 

很粗暴的方法,開兩個數組,存儲好每個人的最遠距離,把一個數組排好序後,和另一個個數組比較,得出名次關係

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;

int T,sum[105],a,b,c,n,i,j,temp[105];

int main()
{
    cin >> T;
    while(T--)
    {
        cin >> n;
        memset(sum,0,sizeof(int)*105);
        memset(temp,0,sizeof(int)*106);
        for(i = 0;i < n;i++)
            {
                cin >> a >>b >> c;
                sum[i] = max(max(a,b),c);
                temp[i] = sum[i];
            }
        for(i = 0;i < n;i++)
            for(j = 0;j < n - 1 - i;j++)
            if(sum[j] < sum[j+1])
        {
            sum[j]+=sum[j + 1];
            sum[j+1] = sum[j] - sum[j+1];
            sum[j] = sum[j] - sum[j+1];
        }
        for(i = 0;i < n;i++)
                for(j = 0;j < n;j++)
                if(sum[j] == temp[i])
                    if(!i) cout << j+1;
                    else cout << " " << j+1;
                cout << endl;
    }
    return 0 ;
}

 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章