1101. Quick Sort (25)

題目如下:

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N = 5 and the numbers 1, 3, 2, 4, and 5. We have:

1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 105). Then the next line contains N distinct positive integers no larger than 109. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:
5
1 3 2 4 5
Sample Output:
3
1 4 5



題目要求找出序列中的所有x,使得x滿足≥前面所有的數,≤後面所有的數,這樣的x稱爲快排中的主元。

爲了快速的判斷,顯然我們需要x左側的最大值和右側的最小值,而且他們一直在變動,一個思路是用兩個vector或者數組記錄每個位置之前最大值、之後最小值,稱爲maxBefore和minBehind,它們的實現邏輯如下:

①第一個元素沒有左側元素,因此maxBefore[0]=-1作爲初始化條件,這樣就保證了必然滿足。

②最後一個元素沒有右側元素,因此minBehind[N-1]=INF(注意INF>10的9次方)。

③對於中間部分,只需要定義max和min兩個變量實時判斷賦值,對於maxBefore,在輸入過程中完成;minBehind通過一次反向遍歷建立。

建立好了兩個表,就可以對每個元素進行查詢,滿足了存入res,如果res規模大於0,則先輸出規模,再輸出排序後的序列;否則輸出0,因爲序列爲空,因此需要空一行,也就是兩個回車符。

代碼如下:

#include <iostream>
#include <vector>
#include <stdio.h>
#include <algorithm>

using namespace std;

int main()
{
    int N;
    cin >> N;
    vector<int> maxBefore(N);
    vector<int> minBehind(N);
    int max = -1, min = 1000000001;
    int num;
    maxBefore[0] = max;
    vector<int> nums(N);
    for(int i = 0; i < N; i++){
        scanf("%d",&num);
        nums[i] = num;
        if(num > max){
            max = num;
        }
        if(i == N - 1) break;
        maxBefore[i+1] = max;
    }
    minBehind[N-1] = min;
    for(int i = N - 1; i >= 1; i--){
        int num = nums[i];
        if(num < min){
            min = num;
        }
        minBehind[i-1] = min;
    }
    vector<int> res;
    for(int i = 0; i < N; i++){
        int num = nums[i];
        if(num >= maxBefore[i] && num <= minBehind[i]){
            res.push_back(num);
        }
    }
    if(res.size()){
        printf("%d\n",res.size());
        sort(res.begin(),res.end());
        printf("%d",res[0]);
        for(int i = 1; i < res.size(); i++) printf(" %d",res[i]);
        cout << endl;
    }else{
        printf("0\n\n");
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章