BFS 1056. Labyrinth

總是出現Runtime Error(SIGSEGV)這個錯誤,後來才發現了是數組越界,本來定義的二維數組,1000*1000,所以棧的數組要是1000*1000而不是1000,已經犯了好幾個這樣的錯誤了,該打,下次一定注意。

現在發現廣搜已經沒有那麼難了,主要是套模板,下一站,深搜!!!

The northern part of the Pyramid contains a very large and complicated labyrinth. The labyrinth is divided into square blocks, each of them either filled by rock, or free. There is also a little hook on the floor in the center of every free block. The ACM have found that two of the hooks must be connected by a rope that runs through the hooks in every block on the path between the connected ones. When the rope is fastened, a secret door opens. The problem is that we do not know which hooks to connect. That means also that the neccessary length of the rope is unknown. Your task is to determine the maximum length of the rope we could need for a given labyrinth.


Input

The input consists of T test cases. The number of them (T) is given on the first line of the input. Each test case begins with a line containing two integers C and R (3 ≤ C, R ≤ 1000) indicating the number of columns and rows. Then exactly R lines follow, each containing C characters. These characters specify the labyrinth. Each of them is either a hash mark (#) or a period (.). Hash marks represent rocks, periods are free blocks. It is possible to walk between neighbouring blocks only, where neighbouring blocks are blocks sharing a common side. We cannot walk diagonally and we cannot step out of the labyrinth.

The labyrinth is designed in such a way that there is exactly one path between any two free blocks. Consequently, if we find the proper hooks to connect, it is easy to find the right path connecting them.


Output

Your program must print exactly one line of output for each test case. The line must contain the sentence "Maximum rope length is X." where Xis the length of the longest path between any two free blocks, measured in blocks.


Sample Input

2
3 3
###
#.#
###
7 6
#######
#.#.###
#.#.###
#.#.#.#
#.....#
#######


Sample Output

Maximum rope length is 0.
Maximum rope length is 8.
#include<iostream>
#include<cstring>
#define MAX 1000006
using namespace std;
const int num=1000;
int visit[num][num],c,r,maxx;
char map[num][num];
struct node
{
	int x,y,l;
}q[MAX],start,endn;
struct{
	int x,y;
}ext[4]={{-1,0},{0,1},{1,0},{0,-1}};
int judge(int x,int y)
{
	return x>=0&&x<r&&y>=0&&y<c&&map[x][y]!='#';
}
void bfs(node s)
{
	maxx=0;
	q[0].x=s.x;
	q[0].y=s.y;
	q[0].l=0;
	memset(visit,0,sizeof(visit));
	visit[s.x][s.y]=1;
	int top=1,xt,yt,xe,ye;
	xe=s.x;
	ye=s.y;
	for(int i=0;i<top;i++)
	{
		for(int j=0;j<4;j++)
		{
			xt=q[i].x+ext[j].x;
			yt=q[i].y+ext[j].y;
			if(judge(xt,yt)&&!visit[xt][yt])
			{
				q[top].x=xt;
				q[top].y=yt;
				q[top].l=q[i].l+1;
				if(maxx<q[top].l)
				{
					maxx=q[top].l;
					xe=q[top].x;
					ye=q[top].y;
				}
				visit[xt][yt]=1;
				top++;
			}
		}
	}
	endn.x=xe;
	endn.y=ye;
}
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		cin>>c>>r;
		int flag=0;
		for(int i=0;i<r;i++)
		{
			for(int j=0;j<c;j++)
			{
				cin>>map[i][j];
			}
		}
		//int flag=0;
		for(int i=0;i<r;i++)
		{
			for(int j=0;j<c;j++)
			{
				if(map[i][j]=='.')
				{
					start.x=i;
					start.y=j;
					flag=1;
					break;
				}
			}
			if(flag)
				break;
		}
		bfs(start);
		bfs(endn);
		cout<<"Maximum rope length is "<<maxx<<"."<<endl;
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章