uva 101 History Grading

Background

Many problems in Computer Science involve maximizing some measure according to constraints.

Consider a history exam in which students are asked to put several historical events into chronological order. Students who order all the events correctly will receive full credit, but how should partial credit be awarded to students who incorrectly rank one or more of the historical events?

Some possibilities for partial credit include:

  1. 1 point for each event whose rank matches its correct rank
  2. 1 point for each event in the longest (not necessarily contiguous) sequence of events which are in the correct order relative to each other.

For example, if four events are correctly ordered 1 2 3 4 then the order 1 3 2 4 would receive a score of 2 using the first method (events 1 and 4 are correctly ranked) and a score of 3 using the second method (event sequences 1 2 4 and 1 3 4 are both in the correct order relative to each other).

In this problem you are asked to write a program to score such questions using the second method.

The Problem

Given the correct chronological order of n events tex2html_wrap_inline34 as tex2html_wrap_inline36 where tex2html_wrap_inline38denotes the ranking of event i in the correct chronological order and a sequence of student responses tex2html_wrap_inline42 where tex2html_wrap_inline44 denotes the chronological rank given by the student to event i; determine the length of the longest (not necessarily contiguous) sequence of events in the student responses that are in the correct chronological order relative to each other.

The Input

The first line of the input will consist of one integer n indicating the number of events withtex2html_wrap_inline50 . The second line will contain n integers, indicating the correct chronological order of n events. The remaining lines will each consist of n integers with each line representing a student's chronological ordering of the n events. All lines will contain nnumbers in the range tex2html_wrap_inline60 , with each number appearing exactly once per line, and with each number separated from other numbers on the same line by one or more spaces.

The Output

For each student ranking of events your program should print the score for that ranking. There should be one line of output for each student ranking.

Sample Input 1

4
4 2 3 1
1 3 2 4
3 2 1 4
2 3 4 1

Sample Output 1

1
2
3

Sample Input 2

10
3 1 2 4 9 5 10 6 8 7
1 2 3 4 5 6 7 8 9 10
4 7 2 3 10 6 9 1 5 8
3 1 2 4 9 5 10 6 8 7
2 10 1 3 8 4 9 5 7 6

Sample Output 2

6
5
10
9

思路:咋一眼一看這道題就很像最長增子串序列問題,只不過有一點變化,該題目的在判斷d[i]與d[j]相比時,b[i]數字能否算在b[j]序列後面,必須要看標準答案中這2個數字的前後順序。另外,這題的輸入是個很大的坑,他的輸入是按照順序,事件1是排在第幾位,事件2是排在第幾位......, 所以要先把輸入轉換成正確的順序。(其次,也有人認爲該題目可以用最長公共子序列模板題,發現其實也是可以的。在此,我給出最長增子序列做法,答案已通過
#include<iostream>
#include<fstream>
#include<stdio.h>
using namespace std;
#define MAXSIZE 25
int a[MAXSIZE];   //用來存放標準答案
int d[MAXSIZE];    //用來表示狀態

bool compare(int x,int y)  //判斷在正確答案中y數據是否在x數據前面
{
    int i;
    for(i=0;i<MAXSIZE;i++)
    {
        if(a[i]==x)
            return true;
        else if(a[i]==y)
            return false;
        else
            ;
    }
    return false;
}
int main()
{
    //ofstream fcout("b.txt");
    //freopen("a.txt","r",stdin);
    int number,i,j;
    cin>>number;
    int temp;
    for(i=0;i<number;i++)
    {
        cin>>temp;
        a[temp]=i+1;
    }
    int b[MAXSIZE];
    int max_score;
    while(cin>>temp)
    {
        b[temp]=1;
        for(i=1;i<number;i++)
        {
            cin>>temp;
            b[temp]=i+1;
        }

        //for(i=1;i<number+1;i++)
           // fcout<<b[i]<<" ";
        //fcout<<endl;
        d[1]=1;
        max_score=d[1];
        for(i=2;i<number+1;i++)
        {
            d[i]=1;
            for(j=1;j<i;j++)
            {
                if(compare(b[j],b[i])&&d[j]+1>d[i])
                    d[i]=d[j]+1;
            }
            if(d[i]>max_score)
                max_score=d[i];
        }
        cout<<max_score<<endl;
    }
    return 0;
}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章