HDU 1498 50 years, 50 colors 二分圖最小點覆蓋(基礎題)

**

50 years, 50 colors

**

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1918 Accepted Submission(s): 1058

Problem Description

On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it’s so nice, isn’t it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named “crashing color balloons”.

There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts “go!”,you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What’s more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons.

Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.

這裏寫圖片描述

Input

There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0.

Output

For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print “-1”.

Sample Input

1 1
1
2 1
1 1
1 2
2 1
1 2
2 2
5 4
1 2 3 4 5
2 3 4 5 1
3 4 5 1 2
4 5 1 2 3
5 1 2 3 4
3 3
50 50 50
50 50 50
50 50 50
0 0

Sample Output

-1
1
2
1 2 3 4 5
-1

題意:n*n的矩形中放入顏色值爲[1,50]的氣球,要求每一個人扎k次,每扎一次,可將同行或者同列相同顏色的氣球全部扎破。求是否存在不可能全部扎破的氣球,按照升序規律輸出氣球的顏色。

題解:對每種顏色進行最小點覆蓋運算,如果最小覆蓋點num>k,則該顏色氣球不能全部扎破。
矩形行列分別爲集合A和集合B,如果判斷顏色k氣球,則如果map[i][j] = k,則表示存在一條邊,這樣便可以轉換成最小點覆蓋問題,只需要找出最小的點,清除掉兩集合之間所有的邊即可。

/*-------------最小點覆蓋運算-------------------

題意:n*n的矩形中放入顏色值爲[1,50]的氣球,要求每一個人扎k次,每扎一次,可將同行或者同列相同顏色的氣球全部扎破。求是否存在不可能全部扎破的氣球,按照升序規律輸出氣球的顏色。

題解:對每種顏色進行最小點覆蓋運算,如果最小覆蓋點num>k,則該顏色氣球不能全部扎破。
矩形行列分別爲集合A和集合B,如果判斷顏色k氣球,則如果map[i][j] = k,則表示存在一條邊,這樣便可以轉換成最小點覆蓋問題,只需要找出最小的點,清除掉兩集合之間所有的邊即。
--------------------------------------------*/

#include <iostream>
#define re(i, n) for(int i = 0; i < n; ++ i)//簡化for循環
using namespace std;

const int nMax = 105;
int map[nMax][nMax];//氣球的總圖
int link[nMax];//link[j]:第j列被扎過時,扎的氣球位置的行(無則-1)
int useif[nMax];//第i列是否被扎過
int ans[nMax];//記錄不能全部扎破的氣球,ans[i]爲某顏色數值
int len;
int n, k;

int dfs(int t, int col)
{
    re(i, n)
    {
        if(!useif[i] && map[t][i] == col)
        {
            useif[i] = 1;
            //尋找增廣路,如果有增廣路,說明該位置需要扎氣球
            if(link[i] == -1 || dfs(link[i], col))
            {
                link[i] = t;//說明i列被扎過,初始扎的氣球位置在t行
                return 1;
            }
        }
    }
    return 0;
}

int maxMatch(int col)
{
    memset(link, -1, sizeof(link));
    int num = 0;
    re(i, n)
    {
        memset(useif, 0, sizeof(useif));//對每一行都要初始化
        if(dfs(i, col)) num ++;
    }
    return num;
}

int main()
{
    //freopen("f://data.in", "r", stdin);
    while(scanf("%d %d", &n, &k) != EOF)
    {
        memset(map, 0, sizeof(map));
        len = 0;
        if(!n && !k) break;
        re(i, n) re(j, n) scanf("%d", &map[i][j]);
        for(int i = 1; i <= 50; ++ i)
        {
            if(maxMatch(i) > k)//每種顏色都判斷一次,執行n次最小點覆蓋
                ans[len ++] = i;
        }
        if(!len) 
            printf("-1\n");
        else
        {
            re(i, len - 1) printf("%d ", ans[i]);
            printf("%d\n",ans[len - 1]);
        }
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章