1083. Moving Tables

Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.
這裏寫圖片描述

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.
這裏寫圖片描述

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move.
Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd
line, the remaining test cases are listed in the same manner as above.
Output

The output should contain the minimum time in minutes to complete the moving, one per line.
Sample Input

3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50
Sample Output

10
20
30


思路

每次搬動桌子經過某個房間時,該房間號經過次數加1,之後對所有房間經過次數排序,其中最大的次數乘以10即爲答案。


代碼

#include <iostream>
#include <algorithm>

using namespace std;

int main()
{
    int N = 0, T = 0;
    int s = 0, t = 0;
    int room[400];

    cin >> T;
    while (T--)
    {
        memset(room, 0, sizeof(room));
        cin >> N;
        while (N--)
        {
            cin >> s >> t;
            if (s > t)
            {
                swap(s, t);
            }
            if (s % 2 == 0)   //以奇數房間進行統計
            {
                s--;
            }
            if (t % 2 != 0)
            {
                t++;
            }
            for (int i = s; i < t; i += 2)
            {
                room[i]++;
            }
        }

        sort(room, room + 399);
        cout << room[398] * 10 << endl;
    }

    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章