2262. Goldbach's Conjecture

Description

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture:
Every even number greater than 4 can be
written as the sum of two odd prime numbers.

For example:
8 = 3 + 5. Both 3 and 5 are odd prime numbers.
20 = 3 + 17 = 7 + 13.
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.)
Anyway, your task is now to verify Goldbach’s conjecture for all even numbers less than a million.
Input

The input will contain one or more test cases.
Each test case consists of one even integer n with 6 <= n < 1000000.
Input will be terminated by a value of 0 for n.
Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying “Goldbach’s conjecture is wrong.”
Sample Input

8
20
42
0
Sample Output

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37


思路

這道題要驗證1000000以內的哥德巴赫猜想。衆所周知,1000000以內哥德巴赫猜想無疑是正確的,所以可以偷懶:程序不會輸出”Goldbach’s conjecture is wrong.”


代碼

#include<iostream>
#include <math.h>

using namespace std;

bool isprime(int a)
{
    int i = 0;

    for (i = 2; i <= sqrt(1.0 * a); i++)
    {
        if (a % i == 0)
            return false;
    }
    return true;
}

int main()
{
    int n = 0,j = 0;

    cin >> n;
    while (n)
    {
        for (j = 3; j < n; j++) //從最小的素數開始,求得的一定是相差最大的素數對
        {
            if (isprime(n - j) && isprime(j))
            {
                cout << n << " = " << j << " + " << n - j << endl;
                break;
            }
        }
        cin >> n;
    }

    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章