A + B Problem II

Hdoj1002:

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
2 1 2 112233445566778899 998877665544332211
 

Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author
Ignatius.L
 
#include <stdio.h>
#include <string.h>
#define N 1000+10
int main(int argc, char **argv)
{
	int n,cas,l1,l2,a[N];
	char s1[N],s2[N];
	scanf("%d",&n);
	for(cas=0;cas<n;)
	{
		memset(a,0,sizeof(a));
		scanf("%s %s",s1,s2);
		l1=strlen(s1);
		l2=strlen(s2);
		int i,j,k;
		for(i=l1-1,j=l2-1,k=0;i>=0&&j>=0;i--,j--,k++)
		{
			a[k]+=s1[i]-'0'+s2[j]-'0';
			if(a[k]>9)
			{
				a[k+1]+=a[k]/10;
				a[k]%=10;
			}
		}
		for(;i>=0;i--,k++)
		{
			a[k]+=s1[i]-'0';
			if(a[k]>9)
			{
				a[k+1]+=a[k]/10;
				a[k]%=10;
			}
		}
		for(;j>=0;j--,k++)
		{
			a[k]+=s2[j]-'0';//j寫成了i,太不小心了;
			if(a[k]>9)
			{
				a[k+1]+=a[k]/10;
				a[k]%=10;
			}
		}
		if(cas)//注意格式;
			printf("\n");
		printf("Case %d:\n",++cas);
		printf("%s + %s = ",s1,s2);
		i=N-1;
		while(!a[i]&&i)//小心全0的情況;
			i--;
		for(;i>=0;i--)
			printf("%d",a[i]);
		printf("\n");
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章