HDU 1671 字典樹


Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 22044    Accepted Submission(s): 7479


Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
NO YES


思路: 每次建邊的時候進行查詢. 不滿足的情況有兩種. 1.在還未建完邊的時候遇到某個電話的末尾 2.在剛好建完邊的時候發現自己這條邊已經被建過了.
          做的時候少考慮一種情況 導致WA1.


源碼:

#include<iostream>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<iomanip>
#include<stdlib.h>
#include<cstdio>
#include<string>
#include<string.h>
#include<set>
#include<stack>
#include<map>
using namespace std;

#define rep(i, n) for(int i=0; i<n ;i++)
typedef long long ll;
typedef  pair<int,int> P;
const int INF = 0x7fffffff;
const int MAX_N = 4e4+5;
const int MAX_V = 0;
const int MAX_M = 0;
const int MAX_Q = 1e5+5;

void show(string a, int val){
	cout<<a<<":       "<<val<<endl;
}

struct Trie{
	bool is_end;
	Trie *nxt[10];
	Trie(){
		is_end = false;
		for(int i=0; i<10; i++){
			nxt[i] = NULL;
		}
	}
};

Trie root;
bool flag;

void add_edge(string str){
	Trie *p = &root, *q;
	for(int i=0; i<str.size(); i++){
		int id = str[i] - '0';
		if(p->nxt[id]!=NULL){
			p = p->nxt[id];
			if(i==str.size()-1)
				flag = false;
		}
		else{
			q = new Trie;
			p->nxt[id] = q;
			p = p->nxt[id];
		}
		if(p->is_end)
			flag = false;
	}
	p->is_end = true;
}

void clear(Trie *q){
	for(int i=0; i<10; i++)
		if(q->nxt[i]!=NULL)
			clear(q->nxt[i]);
	delete q;
}

int main(){
	ios::sync_with_stdio(0);
	int T; cin>>T;
	while(T--){
		for(int i=0; i<10; i++){
			if(root.nxt[i]!=NULL)
				clear(root.nxt[i]);
			root.nxt[i] = NULL;
		}
		string a; int n; cin>>n;
		flag = true;
		for(int i=0; i<n; i++){
			cin>>a;
			if(flag) add_edge(a);
		}
		cout<<(flag?"YES\n":"NO\n");
	}
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章