hdu 1018 (Big Number)

Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

Output
The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input

2
10
20

Sample Output

7
19

題意:給你n組數據,每組數據一個數,求這個數的階乘問你這個數的階乘是幾位數

#include<math.h>
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>

using namespace std;
const int maxn=1001;
typedef long long ll;
const int inf=0x3f3f3f3f;

double reback(int n)
{
    double cnt=0;
    for(int i=2; i<=n; i++)
    {
        cnt+=log10(i);
    }
    return cnt;
}

int main()
{
    int cas,n;
    scanf("%d",&cas);
    while(cas--)
    {
        scanf("%d",&n);
        printf("%d\n",(int)reback(n)+1);
    }
    return 0;
}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章