poj 2299 Ultra QuickSort 樹狀數組+離散化

Ultra-QuickSort

Time Limit: 7000MS

 

Memory Limit: 65536K

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 

9 1 0 5 4 ,


Ultra-QuickSort produces the output 

0 1 4 5 9 .


Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5

9

1

0

5

4

3

1

2

3

0

Sample Output

6

0


#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#define M 500001
using namespace std;
struct node
{
    int v,pos;		
}p[M];
int a[M],n,c[M];//a是離散化數組	

int lowbit(int x)
{
    return x&(-x);
}

void up(int x)
{
    while(x<=n)
    {
        c[x]+=1;
        x+=lowbit(x);
    }
}

int getsum(int x)
{
    int ans=0;
    while(x>0)
    {
        ans+=c[x];
        x-=lowbit(x);
    }
    return ans;
}

bool cmp(const node &a,const node &b)
{
    return a.v<b.v;
}

int main()
{
    int i;
    while(~scanf("%d",&n)&&n)
    {
        for(i=1; i<=n; i++)
        {
            scanf("%d",&p[i].v);
            p[i].pos=i;
        }
        sort(p+1,p+n+1,cmp);
        for(i=1; i<=n; ++i)
            a[p[i].pos]=i;//離散化		
        long long ans=0;
        memset(c,0,sizeof(c));
        for(i=1; i<=n; i++)
        {
            up(a[i]);
            ans+=i-getsum(a[i]);
        }
        printf("%I64d\n",ans);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章