poj 2318 toys 計算幾何+二分

poj 2318

TOYS
     
Total Submissions: 13667   Accepted: 6596

Description

Calculate the number of toys that land in each bin of a partitioned toy box. 
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys. 

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box. 
 
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.


給你n條直線,這些直線把一個矩形分成了n+1個區域,給你一些點,統計每個區域點的個數

思路:枚舉每個點,然後判斷點在哪個區域,通過叉積的符號來判斷點在直線左側還是右側,可以用二分實現


#include<iostream>
#include<cstdio>
using namespace std;
struct Point
{
    int x,y;
    Point (int a=0,int b=0):x(a),y(b) {}
};

inline int  multiply(Point sp,Point  ep,Point op)
{
    return((sp.x-op.x)*(ep.y-op.y)-(ep.x-op.x)*(sp.y-op.y));
}
Point a[5001],b[5001];
int c[5001];
int main()
{
    int N,M,x1,x2,y1,y2,n,m,mid,i;
    while(~scanf("%d",&N))
    {
        if(N<=0) break;
        for(i=0; i<5001; i++)
            c[i]=0;
        scanf("%d %d %d %d %d",&M,&x1,&y1,&x2,&y2);
        for(i=0; i<N; i++)
        {
            scanf("%d %d",&b[i].x,&b[i].y);
            //(b[i].x,y1) (b[i].y,y2);
        }
        int s=0;
        for(i=0; i<M; i++)//toys
            scanf("%d %d",&a[i].x,&a[i].y);
        for(i=0; i<M; i++)
        {
            int left=0,right=N-1;
            while(left<=right)
            {
                mid=(left+right)/2;
                if(multiply(Point(b[mid].x,y1),Point(b[mid].y,y2),a[i])<0)//叉積小於0說明點在直線左側
                    right=mid-1;
                else left=mid+1;
            }
            c[left]++;
        }
        for(i=0; i<=N; i++)
            printf("%d: %d\n",i,c[i]);
        printf("\n");
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章