hdu1075 What Are You Talking About

What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)
Total Submission(s): 10284    Accepted Submission(s): 3270


Problem Description
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
 

Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
 

Output
In this problem, you have to output the translation of the history book.
 

Sample Input
START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i'm fiwo riwosf. i fiiwj fnnvk! END
 

Sample Output
hello, i'm from mars. i like earth!

本題輸入串1,串2,當等於串2時找串1。


AC代碼

#include<iostream>
using namespace std;
struct node
{
	node *next[26];
	char str[10];
	node()
	{
		str[0]='\0';
		memset(next,0,sizeof(next));
	}
};//定義結構體
node *root=NULL;
char str1[10],str2[10];
void build()
{
	node *p=root;
	if(p==NULL)
	{
		root=new node;
		p=root;
	}
	int i=0,j=0;
	while(str2[i])
	{
		j=str2[i]-'a';
		if(p->next[j]==NULL)
			p->next[j]=new node;
		p=p->next[j];
		i++;
	}
	strcpy(p->str,str1);
}//建立字典樹
int findstr()
{
	node *p=root;
	if(p==NULL)
		return 0;
	int i=0,j=0;
	while(str1[i])
	{
		j=str1[i]-'a';
		if(p->next[j]==NULL)
			return 0;
		p=p->next[j];
		i++;

	}
	if(p->str[0]=='\0')
		return 0;
	printf("%s",p->str);
	return 1;
}//搜索str1
int main()
{
   scanf("%s",str1);
   while(scanf("%s",str1)!=EOF)
   {
	   if(strcmp(str1,"END")==0)
		   break;
	   scanf("%s",str2);
	   build();
   }
   scanf("%s",str1);
   getchar();
   int i,flag,j;
   char ch;
   char str[3001];
   while(gets(str)!=NULL)
   {        flag=0;
	   if(strcmp(str,"END")==0)
		   break;
            j=0;
	    for(i=0;str[i]!='\0';i++)
			if(str[i]>='a'&&str[i]<='z')
			{
				str1[j]=str[i];
				j++;
				flag=0;

			}
			else
			{
				ch=str[i];
				if(!flag)
				{
					str1[j]='\0';
				if(!findstr())
					printf("%s",str1);
				flag=1;
				j=0;
				}
				printf("%c",ch);

			}
			printf("\n");
	   
   }
return 0;

}


本題爲字典樹,對於會字典樹的孩子來說是水題!

謝謝閱讀!


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章