hdu1698 Just a Hook

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12774    Accepted Submission(s): 6364


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
1 10 2 1 5 2 5 9 3
 

Sample Output
Case 1: The total value of the hook is 24.
 

題目的題意就是:給你一些牌子(銅,銀,金)分別用1,2,3表示,一開始這些都是銅牌。現在對這些區間區間進行操作,比如說將1到5的牌子塗成銀牌等等。最後統計這些牌子的總價值。
本題爲成段更新,注意更新延遲!

AC代碼


#include <iostream>
using namespace std;
#define maxn 100000
int sum[maxn<<2];
int col[maxn<<2];
void build(int l,int r,int rt)
{
	col[rt]=0;
	sum[rt]=1;//完全初始化
	if(l==r)
		return ;
	
	int m=(r+l)/2;
	build(l,m,rt*2);
	build(m+1,r,rt*2+1);
	sum[rt]=sum[rt*2]+sum[rt*2+1];
}//建立
void pushdown(int rt,int len)
{
	if(col[rt])
	{
		col[rt*2]=col[rt*2+1]=col[rt];
		sum[rt*2]=(len-len/2)*col[rt];
		sum[rt*2+1]=(len/2)*col[rt];
		col[rt]=0;//爲下一次初始
	}

}//延遲操作
void query(int L,int R,int x,int l,int r,int rt)
{
   if(l>=L&&r<=R)
   {
	   col[rt]=x;
	   sum[rt]=(r-l+1)*x;
	   return;
   }
   pushdown(rt,r-l+1);
   int m=(r+l)/2;
   if (L<=m)
     query(L,R,x,l,m,rt*2);
   if(R>m)
	   query(L,R,x,m+1,r,rt*2+1);
   sum[rt]=sum[rt*2]+sum[rt*2+1];
}
int main()
{
	int t,n,q,a,b,c,f=0;
    scanf("%d",&t);
	while (t--)
	{        f++;
		scanf("%d",&n);
		build(1,n,1);
		scanf("%d",&q);
		while(q--)
		{
			scanf("%d%d%d",&a,&b,&c);
			query(a,b,c,1,n,1);		
		}
		printf("Case %d: The total value of the hook is %d.\n",f,sum[1]);

	}
	return 0;
}

本題爲線段樹中成段更新的題目!

謝謝閱讀!


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章