hdu1673 Optimal Parking

Optimal Parking

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1518    Accepted Submission(s): 1295


http://acm.hdu.edu.cn/showproblem.php?pid=1673


Problem Description
When shopping on Long Street, Michael usually parks his car at some random location, and then walks to the stores he needs.
Can you help Michael choose a place to park which minimises the distance he needs to walk on his shopping round?
Long Street is a straight line, where all positions are integer.
You pay for parking in a specific slot, which is an integer position on Long Street. Michael does not want to pay for more than one parking though. He is very strong, and does not mind carrying all the bags around.
 

Input
The first line of input gives the number of test cases, 1 <= t <= 100. There are two lines for each test case. The first gives the number of stores Michael wants to visit, 1 <= n <= 20, and the second gives their n integer positions on Long Street, 0 <= xi <= 99.
 

Output
Output for each test case a line with the minimal distance Michael must walk given optimal parking.
 

Sample Input
2 4 24 13 89 37 6 7 30 41 14 39 42
 

Sample Output
152 70
 

#include<stdio.h>
#include<algorithm>
using namespace std;
int s[24];
int main()
{
	int t,n,i;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=0;i<n;i++)
			scanf("%d",&s[i]);
		sort(s,s+n);
		int ans=(s[n-1]-s[0])*2;
		printf("%d\n",ans);
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章