ZOJ3492 Kagome Kagome

Kagome Kagome

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Kagome kagome, kago no naka no tori wa
Itsu itsu deyaru? Yoake no ban ni
Tsuru to kame to subetta.
Ushiro no shoumen daare?
Translation:
Kagome kagome, the bird in the cage,
when will you come out?
In the evening of the dawn,
the crane and turtle slipped.
Who stands right behind you now?

Kagome Kagome is a Japanese children's game. One child is chosen as the oni (literally demon or ogre, but similar to the concept of "it" in tag) and sits blindfolded (or with their eyes covered). The other children join hands and walk in circles around the oni while singing the song for the game. When the song stops, the oni speaks aloud the name of the person behind him, and if he is correct, the person behind will exchange places with the oni.

Higurashi Tewi is playing Kagome Kagome with her n (n is even) friends as the oni now. She peeps to know who is right in front of her. Knowing the order of the children in circle and assuming that they keep distance evenly, it's easy to derive who is right behind her.

Input

There are multiple test cases. The first line of input is an integer T ≈ 100 indicating the number of test cases.

The first line of each test case starts with an even number 1 ≤ n ≤ 100, followed by the name of the child who is right in front of Higurashi Tewi. The second line contains exactly ndifferent names, listed in counterclockwise order. Name is an alphanumeric string whose length never exceeds 20. It's guaranteed that the child in front of Higurashi Tewi is always contained in the list exactly once.

Output

For each test case, output the name of the child who is right behind Higurashi Tewi.

Sample Input

3
2 Alice
Alice Bob
4 inu
inu neko usagi kizune
4 cat
dog cat rabbit fox

Sample Output

Bob
usagi
fox

#include<stdio.h>
#include<string.h>
char s[104][24];
int main()
{
    int t,i,n,xi,ans;
    while(scanf("%d",&t)!=EOF)
    {
        while(t--)
        {
            scanf("%d%s",&n,s[0]);
            for(i=1; i<=n; i++)
            {
                scanf("%s",s[i]);
                if(!strcmp(s[0],s[i]))
                    xi=i;
            }
            ans=(xi+n/2)%n;
            if(ans==0) ans=n;
            printf("%s\n",s[ans]);
        }
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章