6.19 杭電acm Humble Numbers

 

 

Font Size:

Problem Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence

Input

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.

Sample Input

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

Sample Output

The 1st humble number is 1.The 2nd humble number is 2.The 3rd humble number is 3.The 4th humble number is 4.The 11th humble number is 12.The 12th humble number is 14.The 13th humble number is 15.The 21st humble number is 28.The 22nd humble number is 30.The 23rd humble number is 32.The 100th humble number is 450.The 1000th humble number is 385875.The 5842nd humble number is 2000000000.

 

 

解題代碼:

#include<stdio.h>
#define min(a,b) (a<b?a:b)
#define min4(a,b,c,d) min(min(a,b),min(c,d))
int a[5850];//存放醜數

int main()
{
    int n=1;
    int p2,p3,p5,p7;
    p2=p3=p5=p7=1;//2,3,5,7的計數器
    a[1]=1;
    while(a[n]<2000000000)//從2開始遞推計算,一共5842個醜數
    {
        a[++n] = min4(2*a[p2],3*a[p3],5*a[p5],7*a[p7]);//取最小值,相應的計數器加1
        if(a[n]==2*a[p2]) p2++;
        if(a[n]==3*a[p3]) p3++;
        if(a[n]==5*a[p5]) p5++;
        if(a[n]==7*a[p7]) p7++;
    }
    while(scanf("%d",&n) && n)
    {
        if(n%10 == 1&&n%100!=11)
        printf("The %dst humble number is ",n);
        else if(n%10 == 2&&n%100!=12)
        printf("The %dnd humble number is ",n);
        else if(n%10 == 3&&n%100!=13)
        printf("The %drd humble number is ",n);
        else
        printf("The %dth humble number is ",n);
        printf("%d.\n",a[n]);
    }
    return 0;

}

 

 

本以爲輸出的數是兩位數以上的非質數且不是兩位數以上的質數的倍數

 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章