杭電 1003 Max Sum

http://acm.hdu.edu.cn/showproblem.php?pid=1003

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 142781    Accepted Submission(s): 33242

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 
Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
 
題目要求我們找一個連續子序列的和最大,並且記錄這個序列第一個元素和最後一個元素在原序列中的位置。
AC代碼:
<span style="font-size:24px;">#include<iostream>
using namespace std;
int main()
{
    int i,j,k=0,t,n,a,start,end,max,temp;
    cin>>t;
    for(i=1;i<=t;i++)
    {
        max=-1001,temp=start=k=0;
        scanf("%d",&n);
        for(j=0;j<n;j++)
        {
            scanf("%d",&a);
            temp+=a;
            if(temp>max)
            {
                start=k;
                end=j;
                max=temp;
            }
            if(temp<0)//再往後加會“拖累”後面的和。
            {
                temp=0;
                k=j+1;
            }
        }
        printf("Case %d:\n",i);
        printf("%d %d %d\n",max,start+1,end+1);
        if(i!=t)
            cout<<endl;
    }
    return 0;
}</span>



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章