Message Flood

Message Flood

Time Limit: 1500MS Memory Limit: 65536KB

Problem Description

Well, how do you feel about mobile phone? Your answer would probably be something like that "It's so convenient and benefits people a lot". However, If you ask Merlin this question on the New Year's Eve, he will definitely answer "What a trouble! I have to keep my fingers moving on the phone the whole night, because I have so many greeting message to send!" Yes, Merlin has such a long name list of his friends, and he would like to send a greeting message to each of them. What's worse, Merlin has another long name list of senders that have sent message to him, and he doesn't want to send another message to bother them Merlin is so polite that he always replies each message he receives immediately). So, before he begins to send message, he needs to figure to how many friends are left to be sent. Please write a program to help him. Here is something that you should note. First, Merlin's friend list is not ordered, and each name is alphabetic strings and case insensitive. These names are guaranteed to be not duplicated. Second, some senders may send more than one message to Merlin, therefore the sender list may be duplicated. Third, Merlin is known by so many people, that's why some message senders are even not included in his friend list.

Input

There are multiple test cases. In each case, at the first line there are two numbers n and m (1<=n,m<=20000), which is the number of friends and the number of messages he has received. And then there are n lines of alphabetic strings(the length of each will be less than 10), indicating the names of Merlin's friends, one per line. After that there are m lines of alphabetic strings, which are the names of message senders. The input is terminated by n=0.

Output

For each case, print one integer in one line which indicates the number of left friends he must send.

Example Input

5 3
Inkfish
Henry
Carp
Max
Jericho
Carp
Max
Carp
0

Example Output

3

Hint

Author

第9屆中山大學程序設計競賽預選賽

#include <iostream>
#include <string>
#include <map>
#include <algorithm>
#include <stdio.h>
#include<iomanip>
using namespace std;

int main()
{
    int n, m;
    int i,j;
    while(~scanf("%d",&n) && n != 0)
    {
        scanf("%d",&m);
        map<string, int> mp;
        string name;
        for( i = 0; i < n; i++)
        {
            cin>>name;

            for( j=0; j<name.length(); j++)
            {
                name[j]=tolower(name[j]);
            }
            mp[name] = 1;
        }
        for( i = 0; i < m; i++)
        {
            cin>>name;

            for( j=0; j<name.length(); j++)
            {
                name[j]=tolower(name[j]);
            }
            if(mp[name] == 1)
            {
                n--;
                mp[name] = 0;
            }
        }
        printf("%d\n",n);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章