杭電HDOJ 1097 解題報告


A hard puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23044    Accepted Submission(s): 8089


Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
 

Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
 

Output
For each test case, you should output the a^b's last digit number.
 

Sample Input
7 66 8 800
 

Sample Output
9 6
 

Author
eddy
 

Recommend
JGShining


解題思路:

和1061,我給出的方案1,思路相同。就是找規律,四個一循環,取末位數,進行相乘,然後取最末位數字。


代碼:

#include<stdio.h>
int main()
{
    int i,pro;
    long a,b;
    while(scanf("%ld%ld",&a,&b)!=EOF)
    {
        pro=1;
        b=(b-1)%4;
        a=a%10;
        for(i=0;i<=b;i++)
            pro*=a;
        printf("%d\n",pro%10);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章