杭電HDOJ 1160 解題報告

FatMouse's Speed

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6632    Accepted Submission(s): 2898
Special Judge


Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
 

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed. 
 

Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that 

W[m[1]] < W[m[2]] < ... < W[m[n]]

and 

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 
 

Sample Input
6008 1300 6000 2100 500 2000 1000 4000 1100 3000 6000 2000 8000 1400 6000 1200 2000 1900
 

Sample Output
4 4 5 9 7
 

Source
 

Recommend
Ignatius

這是一道DP的題目,之前已經上了好幾題DP的了。。。繼續。

解題思路:

對W或S排序後,對另一個進行DP。

(未完待續,下次上圖說明)




代碼:

#include <stdio.h>

int main(int argc, const char * argv[])
{
    int a[1005],b[1005],c[1005],d[1005],i,j,k,t,m=0,w,v[1005]={-1};
    i=0;
    while(scanf("%d",&a[i])!=EOF/*&&a[i]!=0*/)
    {
        scanf("%d",&b[i++]);
    }
    //sort
    for(j=0;j<i;j++)
    {
        t=0;
        for(w=0;w<i;w++)
        {
            if(a[w]>t)
            {
                t=a[w];
                k=w;
            }
        }
        c[m++]=k;
        a[k]=0;
    }
    //find max
    for(j=0;j<i;j++)
    {
        k=c[j];
        w=j;
        if(j==0) {d[k]=1;v[k]=-1;}
        else{
            m=1;
            for(t=c[w-1];w>=0;w--)
            {
                t=c[w-1];
                if(b[k]>b[t])
                {if(d[t]>=m) {m=d[t]+1;v[k]=t;}}
            }
            d[k]=m;if(m==1) v[k]=-1;
        }
    }
    // output
    t=0;
    for(j=0;j<i;j++)
    {
        k=c[j];
        if(d[k]>t) {t=d[k];w=c[j];}
    }
    printf("%d\n",t);
    //print
    printf("%d\n",w+1);
    while(d[w]!=1){
        w=v[w];
        if(w==-1) break;
        printf("%d\n",w+1);
    }
    
    return 0;
}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章