杭電HDOJ 1001 解題報告

Sum Problem

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 209891    Accepted Submission(s): 50826


Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 

Input
The input will consist of a series of integers n, one integer per line.
 

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 

Sample Input
1 100
 

Sample Output
1 5050
 

Author
DOOM III


解題思路:

1、for循環;(遞歸或靜態函數和for循環是一樣的

2、高斯定理;


代碼:

1、

#include<stdio.h>
main()
{
    long double i,n,sum;
    while(scanf("%lf",&n)!=EOF)
    {
        sum=0;
        for(i=1;i<=n;i++)
        {
            sum+=i;
        }
        printf("%.0lf\n\n",sum);
    }
}


2、

#include<stdio.h>
main()
{
    long double n;
    while(scanf("%lf",&n)!=EOF)
    {
        printf("%.0lf\n\n",n/2*(n+1));
    }
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章