POJ 2352 stars 樹狀數組

Stars

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

題意:給出N個星星在二維平面上的座標x,y(座標按y遞增順序給出,y相同時按x遞增給出)。定義每個星星的level爲橫縱座標均不超過自己的星星個數,依次給出level爲0~N-1的星星分別有多少個。

因爲按照y遞增給出,所以第i顆星星等級就是之前出現過的星星中x座標小於等於它的x座標的星星數量,利用樹狀數組求和最合適。(爲防止出現x=0,每一個x均執行x++右移一位)

#include<iostream>
#include<cstdio>

using namespace std;
const int maxn = 32001;
int level[maxn], c[maxn];
int lowbit(int x)
{
	return x&(-x);
}
int sum(int x)
{
	int sum = 0;
	while (x>0)
	{
		sum += c[x];
		x -= lowbit(x);
	}
	return sum;
}
void update(int pos)
{
	while (pos <= maxn)
	{
		c[pos]++;
		pos += lowbit(pos);
	}
}
int main()
{
	int n,x,y;
	scanf("%d", &n);
	for (int i = 0; i < n; i++)
	{
		scanf("%d %d", &x, &y);
		x++;
		level[sum(x)]++;
		update(x);
	}
	for (int i = 0; i < n; i++)
	{
		printf("%d\n", level[i]);
	}
	return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章