HDU 3555 Bomb

題目鏈接:http://acm.hdu.edu.cn/showproblem.php?pid=3555


Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)

Total Submission(s): 15270    Accepted Submission(s): 5515



Problem Description

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output

For each test case, output an integer indicating the final points of the power.
 

Sample Input

3 1 50 500
 

Sample Output

0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
 

Author

fatboy_cw@WHU
 

Source

 

Recommend

zhouzeyong


思路:經典的數位DP。自己不太懂這個知識點,參考了一位大神的博客,很詳細,如下所示。

http://www.cnblogs.com/liuxueyang/archive/2013/04/14/3020032.html


附上AC代碼:

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn = 25;
ll dp[maxn][3];
int num[maxn];
ll n;

void init(){
	dp[0][0] = 1;
	for (int i=1; i<maxn; ++i){
		dp[i][0] = dp[i-1][0]*10-dp[i-1][1];
		dp[i][1] = dp[i-1][0];
		dp[i][2] = dp[i-1][2]*10+dp[i-1][1];
	}
}

int main(){
	init();
	int T;
	scanf("%d", &T);
	while (T--){
		scanf("%I64d", &n);
		ll ans = 0;
		bool ok = false;
		int len = 0;
		while (n){
			num[++len] = n%10;
			n /= 10;
		}
		for (int i=len; i>=1; --i){
			ans += dp[i-1][2]*num[i];
			if (ok)
				ans += dp[i-1][0]*num[i];
			if (!ok && num[i]>4)
				ans += dp[i-1][1];
			if (i+1<=len && num[i+1]==4 && num[i]==9)
				ok = true;
		}
		if (ok)
			++ans;
		printf("%I64d\n", ans);
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章