poj 1724

ROADS
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14615   Accepted: 5298

Description

N cities named with numbers 1 ... N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins). 
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash. 

We want to help Bob to find the shortest path from the city 1 to the city N that he can afford with the amount of money he has. 

Input

The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way. 
The second line contains the integer N, 2 <= N <= 100, the total number of cities. 

The third line contains the integer R, 1 <= R <= 10000, the total number of roads. 

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters : 
  • S is the source city, 1 <= S <= N 
  • D is the destination city, 1 <= D <= N 
  • L is the road length, 1 <= L <= 100 
  • T is the toll (expressed in the number of coins), 0 <= T <=100

Notice that different roads may have the same source and destination cities.

Output

The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins. 
If such path does not exist, only number -1 should be written to the output. 

Sample Input

5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2

Sample Output

11

題解:從1出發到n地點,在有限的錢數內,找到最短的路徑,可以採用鏈式前向星存儲加上優先隊列(bfs),還可以採用dfs當距離變大就回溯,遍歷所有點找到最小的路徑。

代碼1:

#include<stdio.h>
#include<string.h>
#include<queue>
#define Max 10005
#define INF 0x3f3f3f
using namespace std;
typedef struct nod {
	int to;
	int next;
	int length;
	int money;
}nod;
struct s{
	int num;
	int length;
	int money;
};

bool operator < (s node1, s node2) {
		return node1.length > node2.length;
}

nod edge[Max];
priority_queue<s>que;
int head[105];
int count, k, n, r; 

void add(int s, int d, int l, int t) {
	edge[count].to = d;
	edge[count].length = l;
	edge[count].money = t;
	edge[count].next = head[s];
	head[s] = count++;
}

void spfa() {
	s temp, nn;
	int u;
	int act = -1;
	while(!que.empty())
		que.pop();
	temp.length = 0;
	temp.num = 1;
	temp.money = 0;
	que.push(temp);
	while(!que.empty()) {
		temp = que.top();
		que.pop();
		if(temp.num == n) {
			act = temp.length;
			break;
		}
		for(u = head[temp.num]; u != -1; u = edge[u].next) {
			if(temp.money + edge[u].money <= k) {
				nn.money = temp.money + edge[u].money;
				nn.length = temp.length + edge[u].length;
				nn.num = edge[u].to;
				que.push(nn);
			}		
		}
	}
	printf("%d\n", act);
}

int main(){
	int s, d, l, t, i;
	while(scanf("%d%d%d", &k, &n, &r) != EOF) {
		count = 1;
		memset(head, -1, sizeof(head));
		for(i = 1; i <= r; i++) {
			scanf("%d%d%d%d", &s, &d, &l, &t);
			add(s, d, l, t);
		}
		spfa();
	}
}
 

代碼2:

#include<stdio.h>
#include<string.h>
#include<queue>
#define Max 10005
#define INF 0x3f3f3f
using namespace std;
typedef struct nod {
	int to;
	int next;
	int length;
	int money;
}nod;
struct s{
	int num;
	int length;
	int money;
};
int visited[105];
nod edge[Max];
int head[105];
int count, k, n, r, ans; 

void add(int s, int d, int l, int t) {
	edge[count].to = d;
	edge[count].length = l;
	edge[count].money = t;
	edge[count].next = head[s];
	head[s] = count++;
}

void dfs(int num, int dis, int money) {
	int i;
	if(dis > ans)
		return;
	if(num == n && money >= 0 && dis < ans)
		ans = dis;
	for(i = head[num]; i != -1; i = edge[i].next) {
		if(!visited[edge[i].to] && money >= edge[i].money) {
			visited[edge[i].to] = 1;
			dfs(edge[i].to, dis + edge[i].length, money - edge[i].money);
			visited[edge[i].to] = 0;
		}
	}	
}

int main(){
	int s, d, l, t, i;
	while(scanf("%d%d%d", &k, &n, &r) != EOF) {
		count = 1;
		memset(visited, 0, sizeof(visited));
		memset(head, -1, sizeof(head));
		for(i = 1; i <= r; i++) {
			scanf("%d%d%d%d", &s, &d, &l, &t);
			add(s, d, l, t);
		}
		ans = INF;
		dfs(1, 0, k);
		if(ans != INF)
			printf("%d\n", ans);
		else
			printf("-1\n");
	}
}
 


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章