hdu 1385

Minimum Transport Cost

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10562    Accepted Submission(s): 2931


Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.
 

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
 

Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

 

Sample Input
5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0
 

Sample Output
From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4

Total cost : 17

題解:要求每個點之間的最小花費,Floyd算法,在算法中比較時,應加上到達每個點之間的運費,並且如果存在兩條花費相同的路徑,要輸出字典序最小的那條路徑, 如果要求從1到1之間的最小花費和路徑的話,在輸出的時候,路徑只能輸出1,不能輸出1-->1,注意這種輸出的格式,我就吃了很大的虧。

代碼:

#include<stdio.h>
#include<string.h>
#define INF 1000000000
int path[1000][1000], map[1000][1000], verx[1000][2], tax[1000], n, count;
void floyd() {
	int i, j, k;
	for(k = 1; k <= n; k++)
		for(i = 1; i <= n; i++)
			for(j = 1; j <= n; j++) {	
					if(map[i][j] == map[i][k] + map[k][j] + tax[k] && path[i][j] > path[i][k]) {
						path[i][j] = path[i][k];
					}
					else if(map[i][j] > map[i][k] + map[k][j] + tax[k]){
						map[i][j] = map[i][k] + map[k][j] + tax[k];
						path[i][j] = path[i][k];
					}
				}	 
}

void outPut() {
	int i, tempPath[1000], number, street, j;
	for(i = 0; i < count; i++) {
		number = 0;
		street = path[verx[i][0]][verx[i][1]];
		while(street != verx[i][1]) {
			tempPath[number++] = street;
			street = path[street][verx[i][1]];
		}
		printf("From %d to %d :\n", verx[i][0], verx[i][1]);
		if(verx[i][0] - verx[i][1] == 0)
			printf("Path: %d\n", verx[i][0]);
		else
			printf("Path: %d-->", verx[i][0]);
		for(j = 0; j < number; j++) {
			printf("%d-->", tempPath[j]);

		}
		if(verx[i][0] - verx[i][1] != 0)
			printf("%d\n", verx[i][1]);
		printf("Total cost : %d\n", map[verx[i][0]][verx[i][1]]);
		printf("\n");
	}
}

int main() {
	int i, j, value, start, end;
	while(scanf("%d", &n), n != 0) {
		count = 0;
		for(i = 1; i <= n; i++)
			for(j = 1; j <= n ; j++)
				path[i][j] = j;
		for(i = 1; i <= n; i++)
			for(j = 1; j <= n; j++) {
				scanf("%d", &value);
				if(value == -1)
					map[i][j] = INF;
				else
					map[i][j] = value;
			}
		for(i = 1; i <= n; i++) {
			scanf("%d", &value);
			tax[i] = value;
		}
		while(scanf("%d%d", &start, &end)) {
			if(start == -1 && end == -1)
				break;
			verx[count][0] = start;
			verx[count][1] = end;
			count++;
		}
		floyd();
		outPut();
	}
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章