UVA 424

Description

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.

``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670

n個大數相加,把C提前初始化並確保最後檢索0輸出

#include <bits/stdc++.h>
using namespace std;
#define MAXN 100
#define MAXN_E 500000   //邊可能很多
char A[100000], B[100000], C[100000];
void Cal(char *A, char *B, int lenA, int lenB)
{
    int add = 0;A[0] = 0;//進位
    for (int i = lenA, j = lenB;i>0;i--, j--)
    {
        int dia = A[i] - '0' + add;
        dia = i <= lenA - lenB ? dia : dia + B[j] - '0';
        C[i] = dia % 10 + '0';
        add = dia / 10;
    }
    C[0] = add ? '1' : '0';
}
void Scan(void)
{
    for(int i=0;i<=1000;i++) C[i] = '0';   //這步比較重要
    while(scanf("%s", A + 1))
    {
        if(A[1]=='0') break;
        int lena = strlen(A + 1), lenc = strlen(C + 1);
        lena > lenc ? Cal(A, C, lena, lenc) : Cal(C, A, lenc, lena);
    }
}
void Print(void)
{//除去前置0
    int k;for (k = 0;C[k] == '0';k++);
    printf("%s\n", C + k);
}
int main(void)
{
    //freopen("F:\\test.txt","r",stdin);
    Scan();Print();
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章